라즈베리파이 배포판 업그레이드 (jessie -> stretch)

라즈베리파이에 워드프레스를 설치하여 이 페이지를 운용중이다. 언제부터인가 워드프레스를 업데이트 하려면 php 버전 7 이상이 필요하다며 업데이트가 안되었다. 시간이 좀 있어서 php7을 설치해보기로 했다.

좀 검색을 해보니 지금 사용하는 jessie 배포판은 좀 오래된 버전으로 php5를 포함하고있다. 최신판인 stretch를 설치하면 php7을 포함하므로 자연스럽게 업그레이드가 될 것 같아서 배포판 업그레이드를 하기로 결정했다.

Raspberry Pi - Raspbian-Update "Jessie" to "Stretch"
Upgrade Raspbian “Stretch”

배포판 업그레이드는 https://www.datenreise.de/en/raspberry-pi-raspbian-update-update-jessie-to-stretch/ 페이지를 보면서 따라가면 별 문제 없이 할 수 있다. 몇 가지 패키지에 문제가 있었는데 사용하지 않는 패키지라 지워버리고 진행하니 문제가 없었다.

배포판 업그레이드 후 첫 번째 문제는 php5가 남아있다는 것이다. phpinfo를 보니 php5가 출력이 되었다. php5를 지우고 php7관련 패키지들을 다시 설치하여 php7으로 넘어갈 수 있었다. php7.0-pdm 패키지가 설치되면서 mysql, apache등이 연동이 되었던 것 같다.

이렇게 php7이 설치되니까 워드프레스도 자연스럽게 업데이트가 되어 잘 동작했다.

그런데 따로 만들어둔 페이지들이 하나도 동작하지 않았다. 좀 찾아보니 mysql_* 함수들을 mysqli_* 함수들로 변경해야 한다고. 그래서 일일이 찾아서 바꿔주니 에러는 나지 않았는데 쿼리 결과가 NULL이 리턴되었다. mysqli_query 함수를 찾아보니 mysqli 인자를 필수로 넘겨줘야 하는 것 같았다. mysqli_query($query) -> mysqli_query($conn, $query)로 변경해주니 쿼리 결과가 제대로 넘어왔다.

이걸 일일이 다 바꿔주는 방법밖에 없는건지 모르겠지만 일단 급하니 하나하나 바꿔줘야 할 듯… 여튼 라즈베리파이의 배포판을 업그레이드하였으니 큰 일 하나 해낸 듯.. 🙂

댓글 남기기